Question

How to enable mod_rewrite on LEMP Ubuntu

Posted August 3, 2016 7.5k views
NginxUbuntuDigitalOceanLEMP

I have created a website in a droplet, and I have uploaded sendy files to a subdirectory.
After installing the sendy it gives 404 error.
In their documentation it says that i need to enable mod_rewrite. I have tried all answers here in digitalocean community nothing fixed for me.

Before reading further, please verify that the .htaccess file has been uploaded.

As part of the compatibility checklist, mod_rewrite needs to be enabled.

I tried to edit .htaccess file and tried to add try_files $uri $uri/ /index.php?$args; in server { but nothing worked.

Can anyone help me out with this problem?
Thanks.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

Okay, so nginx doesn’t use .htaccess, delete it, it’s useless.

And it should be

location / {
        try_files $uri $uri/ /index.php?q=$request_uri;
}

Also make sure php5-fpm or hhvm is working! (depends on what you use)

Can someone willing to take a look at my config and help to fix this problem?
Tried everything still the sub-directory is not working properly.

Yes, paste it on dpaste.com, and I’ll look at it :-)

  • path /etc/nginx/sites-enabled/(mywebsitefolder)

    http://dpaste.com/0QYYNRN

    I have done this it’s going inside now. But the other than that It doesn’t goes to any pages like settings, etc. it just stays in index.php

    I think something needs to change in the try_files

Sorry, no idea why it doesn’t work :(

Can someone please check and help me out?

Submit an Answer