Question

How to enable mod_rewrite on LEMP Ubuntu

I have created a website in a droplet, and I have uploaded sendy files to a subdirectory. After installing the sendy it gives 404 error. In their documentation it says that i need to enable mod_rewrite. I have tried all answers here in digitalocean community nothing fixed for me.

Before reading further, please verify that the .htaccess file has been uploaded.

As part of the compatibility checklist, mod_rewrite needs to be enabled.

I tried to edit .htaccess file and tried to add try_files $uri $uri/ /index.php?$args; in server { but nothing worked.

Can anyone help me out with this problem? Thanks.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Okay, so nginx doesn’t use .htaccess, delete it, it’s useless.

And it should be

location / {
        try_files $uri $uri/ /index.php?q=$request_uri;
}

Also make sure php5-fpm or hhvm is working! (depends on what you use)

Can someone please check and help me out?

Sorry, no idea why it doesn’t work :(

Yes, paste it on dpaste.com, and I’ll look at it :-)

Can someone willing to take a look at my config and help to fix this problem? Tried everything still the sub-directory is not working properly.