Hello Team,

I have set up the virtual host for my website. Directory structure is
www/html/-virtual host(website1.ca)/public_html/wordpress files
-main website’s files(website.ca)

i.e in html folder I have main website’s all files and domain name of virtual host http://prntscr.com/pphfdz . I have followed all the steps given in https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-16-04 . It only enable SSL certificate for main website but not enabling SSL certificate for website which is on virtual host. It is showing that website is not secure http://prntscr.com/pphhkw for website who is set up on the virtual host.

Can you please guide me so that I can enable SSL certificate for website that is on virtual host?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @Web1developer,

I assume you have certbot installed as you’ve already managed to issue some certificates, can you try the following now

 certbot --apache -d example.com -d www.example.com

For this example, the base domain will be example.com and you’ll need to change it to the one you wish

If you have multiple virtual hosts, you should run certbot once for each to generate a new certificate for each. You can distribute multiple domains and subdomains across your virtual hosts in any way.

Regards,
KDSys

Submit an Answer