Question

How to execute wordpress instance migration seamlessly (Droplet: Ubuntu 20.04 - OpenLiteSpeed Wordpress)

Posted August 27, 2020 167 views
WordPressMariaDBOpenLiteSpeed WordPress 1-Click

Hey guys,

I’m just trying to figure out what are the remaining steps for a graceful transition between my old web host and my new droplet.

Here’s what I’ve done so far:

  • Setup my droplet to target my subdomain (do.mydomain.com)
    • Also used Certbot automatic setup at when I first launched the server to issue certificates for this subdomain.
  • Copied my Wordpress DB and files.
  • Updated config files and php.ini.
  • Tested that everything works fine through do.mydomain.com
  • Installed OLS plugin on the new Wordpress instance and setup everything

So that’s the base setup. Now I began the migration but after struggling with certbot, I had no choice to stop for today ( Error creating new order :: too many failed authorizations recently: ). I’d like for everything to go well tomorrow then I try again.

I seem to be lost when it comes to make sure my droplet is ready for the main domain name (leaving do.mydomain.com for just mydomain.com).

I never used certbot before this droplet. Never setup a web server beforehand to be honest. Moving from a CPanel installation that will stay alive on the other host just because it’s cheaper than a licence and my emails are using CPanel forwarding features.

So what I done so far (all on the droplet):

  • Changed home and siteurl in wp_options in the DB for mydomain.com instead of do.mydomain.com.
  • Added listeners for www.mydomain.com and mydomain.com to my OLS admin panel (edited the ones already there for do.mydomain.com and just added the two domain names above).
  • Edited my Domain Registrar A Record for mydomain.com to point to my droplet IP’s address.
  • Ran certbot certonly, specifying “Places files in webroot” (which is the same and only webroot as do.mydomain.com, /var/www/html/). Specified the domain name mydomain.com a few times, kept failing, so I specified the domain names mydomain.com, do.mydomain.com and it gave me the “Expand certificate” option, which I selected. Finally got the “Too many failed authorizations” error which is where I’m at now.

For the time being I changed back my A Record for my main domain name back to my old web host since I’m having about 100 concurrent visitors all the time…

I really need the switch to be seamless and the certificate thing fixed. Any tips for tomorrow ? Anything I forget ? Thanks in advance for your help.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi,

You probably just hit the certbot rate limit due to frequent requests, please add --dry-run parameter when you are doing certbot test.

Here’s an no interactive example when you want to expand the domain.

certbot certonly --non-interactive --agree-tos -m supportexample.com --webroot -w /var/www/html/ -d example.com -d do.exmaple.com -d www.example.com --expand --dry-run

Once you see output like below, then you can run the certbot command again without --dry-run

IMPORTANT NOTES:
 - The dry run was successful.

Remember to restart the web server to reload certificate.

service lsws restart

If challenge failed again, please share the output here.

Hope it helps.

  • Thank you very much @eleu. It seems like the certificate was the only thing I needed for everything to work smoothly… and now it does ! The --dry-run parameter really helped me a lot to debug things out.

    Have a great day!

Submit an Answer