Question

how to extend limit of import file in phpmyadmin

  • Posted December 28, 2014

hello, I’m using ubuntu 12.04 , i have setup mysql, phpadmin all, when i was ready to import my sql back up and it’z size around 105mb, but the current limit is (Max: 2,048KiB) in import. it is very low , so can any one please explain me how to extend this limit.

Thank’s in advance.

P.S share proper steps or refer link of tutorial.

Subscribe
Share

you need to three changes in php.ini file. nano /etc/php5/apache2/php.ini memory_limit post_max_size upload_max_filesize e.g: memory_limit 128M post_max_size 12M upload_max_filesize 10M Don’t forget to restart apache service.

@kamaln7 you here? Please help me out.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Edit /etc/php5/apache2/php.ini, set upload_max_filesize and post_max_size to 150M and restart Apache:

sudo service apache2 restart

You should then be able to upload your SQL dump using phpMyAdmin.

Once you’ve done that, it’s safer to lower the size limit back to a reasonable value like 8M or so. Don’t forget to restart Apache after editing php.ini.

Edit /etc/php5/apache2/php.ini, set upload_max_filesize and post_max_size to 150M and restart Apache:

sudo service apache2 restart

You should then be able to upload your SQL dump using phpMyAdmin.

Once you’ve done that, it’s safer to lower the size limit back to a reasonable value like 8M or so. Don’t forget to restart Apache after editing php.ini.

Edit /etc/php5/apache2/php.ini, set upload_max_filesize and post_max_size to 150M and restart Apache:

sudo service apache2 restart

You should then be able to upload your SQL dump using phpMyAdmin.

Once you’ve done that, it’s safer to lower the size limit back to a reasonable value like 8M or so. Don’t forget to restart Apache after editing php.ini.

Edit /etc/php5/apache2/php.ini, set upload_max_filesize and post_max_size to 150M and restart Apache:

sudo service apache2 restart

You should then be able to upload your SQL dump using phpMyAdmin.

Once you’ve done that, it’s safer to lower the size limit back to a reasonable value like 8M or so. Don’t forget to restart Apache after editing php.ini.

To Increase Upload File Size Limit Via FTP:

  1. Login with your SSH root password.

  2. Choose SFTP and connect. within /etc folder search for php.ini file and change the three php.ini files in the following folders

/php/7.2/cli/ /php/7.2/cgi/ /php/7.2/apache2/ folders

(depending on php version, folders might be different)

memory_limit 128M post_max_size 128M upload_max_filesize 128M

Restart Apache Server

Hello, all

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of upload_max_filesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 200M

You also need to restart your web server in order the changes to take effect.

Hope that this helps! Regards, Alex

I uploaded and imported file: Orders.sql of 700mb to Database: myshop from OSX Terminal:

scp ~/Downloads/Orders.sql root@MY_SSH_IP:/root/Orders.sql
ssh root@MY_SSH_IP
mysql -u root -p myshop < Orders.sql

Delete the uploaded file:

rm /root/Orders.sql

I tried all mentioned above. But it is not working :( My current php version is PHP6 where file import in db is not working. My my initial php version, it is working absolutely fine - PHP 5 please suggest

After Several hours trying to figure out why changes to php.ini doesn’t work on max upload size, i decided to take other path…so here goes the…

Ways of making work changes to upload_max_filesize, or php.ini max upload size doesn’t work:

FIRST remember to also increase post_max_size just in case is that the limit as that one overrides upload_max_filesize…

Here goes the ways to make work upload_max_filesize without touching PHP.ini!!!

APACHE Add next content to .htaccess file at your app or site directory:

<IfModule mod_php5.c> php_value upload_max_filesize 40M php_value post_max_size 40M </IfModule>

or

NGINX Add this to the conf file of the site or application (usually at /etc/nginx/sites-available)

location ~ .php$ { fastcgi_param PHP_VALUE “upload_max_filesize = 50M \n post_max_size=51M”; }

or

CREATE A FILE user.ini (where user is the user that have access to that folder, usually files are owned by this user) put this file on the directory where the php is located, user.ini must have next content:

upload_max_filesize = 40M

post_max_size = 40M

or

PHP CODE Inside the php that must upload the file or files at the top inside php brackets of course, put:

ini_set(‘post_max_size’, ‘64M’); ini_set(‘upload_max_filesize’, ‘64M’);


One of this solutions must work, in my case was the Apache one, and worked perfect, try yours!!!