How to fix DNS resolution?

October 2, 2018 1.1k views
DNS Ubuntu 18.04

Hi Everyone, newbie here. I have set up and redirected my domian with (AWS Route53) to Digital Ocean nameserver but I am still have problem with DNS resolution. I ran a demo app in Python (using Django) virtual environment but the page was unable to load with error message,’ Connection Timed Out’. Please see what I have setup on AWS and DO control panel. I will greatly appreciate your help. Thank you very much.
AWS route 53:
ns1.digitalocean.com
ns2.digitalocean.com
ns3.digitalocean.com

Digital Ocean:
A record devparticle.com >>>>>> droplet ip_address
NS devparticle.com >>>> ns1.digitalocean.com
NS devparticle.com >>>> ns2.digitalocean.com
NS devparticle.com >>>> ns3.digitalocean.com

2 Answers

You don’t need to setup DNS at both Digitalocean and Route 53. One should do. But at either one of these there needs to be an A record defined to point at your droplet’s IP. Right now your domain’s whois info still shows AWS 53 as your name servers:

 $ whois -f devparticle.com|grep Server
   Registrar WHOIS Server: whois.registrar.amazon.com
   Name Server: NS-1438.AWSDNS-51.ORG
   Name Server: NS-1969.AWSDNS-54.CO.UK
   Name Server: NS-464.AWSDNS-58.COM
   Name Server: NS-652.AWSDNS-17.NET

But the above name servers refuse to answer basic DNS queries against devparticle.com:

$ dig devparticle.com  @ns-652.awsdns-17.net +norec

; <<>> DiG 9.10.3-P4-Ubuntu <<>> devparticle.com @ns-652.awsdns-17.net +norec
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, **status: REFUSED**, id: 57295
;; flags: qr; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;devparticle.com.       IN  A

;; Query time: 37 msec
;; SERVER: 205.251.194.140#53(205.251.194.140)
;; WHEN: Tue Oct 02 18:28:57 CDT 2018
;; MSG SIZE  rcvd: 33

This means there’s a misconfiguration at Route 53’s end. That’s where I’d check things.

@unixynet After following the information you provided, I was able to resolve my DNS. I greatly appreciate your input and thank you very much.

Have another answer? Share your knowledge.