Question

How to fix PHP Fatal error: Uncaught --> Smarty: unable to write file

I just setup a new droplet on which I unzipped a prestashop installation.

I get this error when trying to access the admin area:

PHP Fatal error:  Uncaught  --> Smarty: unable to write file /var/www/testapp/public_html/cache/smarty/compile/9b/4f/93/wrt5513f60bb63d41_15387074 <-- \n  thrown in /var/www/testapp/public_html/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46

I’ve tried the following without any luck:

codesudo chown -R www-data:www-data /var/www/testapp/public_html/
sudo chown -R $USER:$USER /var/www/testapp/public_html/
tried with permissions 777 over cache folder - still doesn't work

Any suggestions? I’ve found many other users with this problem but none of their fixes worked for me.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You should change directories permissions to 755 and files permissions to 644. Have you also checked your .htaccess file isn’t corrupt?

If you logged as root user don’t use this ($USER:$USER) like below,

sudo chown -R $USER:$USER /var/www/testapp/public_html/

you should use this code for, give the permissions

sudo chmod -R 755 /var/www

please recreate your droplet (instance) and try again.

for more details https://www.digitalocean.com/community/tutorials/how-to-set-up-nginx-server-blocks-virtual-hosts-on-ubuntu-16-04

We can use the $USER environmental variable to assign ownership to the account that we are currently signed in on (make sure you’re not logged in as root). This will allow us to easily create or edit the content in this directory:

@catalinmn and @MatthewTV I know this comes a few years after the initial discussion, but I have a scenario here…

I applied the above solution:

find /var/www/testapp/public_html/cache -type d -exec chmod 755 {} ; find /var/www/testapp/public_html/cache -type f -exec chmod 644 {} ;

And now my XAMPP app does not want to open anymore.

I am using a Mac.

Any suggestions how to approach this issue?

I have been struggling with this mysql/xampp/apache startup for 2 days now…