How to force docker-machine to use private IP instead public

August 3, 2018 302 views
Docker

Hi,

I'm using GitLab runners in autoscale mode with DigitalOcean.
I notice that GitLab runner by using Docker Machine use Public IP instead Private.
I precise --digitalocean-private-networking option, but it changes nothing.

When I docker-machine inspect my-machine I saw "PrivateNetworking": true but "IPAddress" is a public one.

Does this the normal behavior? Does this could be changed?

Thanks.

Be the first one to answer this question.