Question

How to handle SFTP clients after disabling root user

Hi,

I recently setup my first droplet, I basically configured it following these two tutorials.

1- Server Setup

2- Additional Recommended

I have been SSHing from the terminal and everything works fine. Today I tried to use my FTP client (Transmit) and I realized that since I disabled the root user and because I’m using a user who requires the use of ‘sudo’ this wasn’t going to be possible and I was right, I cannot upload files to folder that outside my user folder.

How is this typically handled?

How can I use my FTP program to upload files to my server?

Do I need to enable the root user?

Can someone be so kind and give me some direction?

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You don’t need to activate root to do that.

In Transmit check these settings: Protocol: choose SFTP Server: your full domain name or IP user name: your sudo username (not root)

Port: only enter somthing here if you changed the default port 22 to something else

Once you start modifying files on your server via Transmit you may run into permission issues. If you do connect via SSH to your server and type this into the command line:

chown -R demouser. /var/www/html
  • change “demouser” to your name (keep the dot at the end)
  • change “/var/www/html” to whatever your folder structure is you need to change

Hi. For those of you, who is still facing the problem with Transmit working with encrypted keys. Maybe, before chowning on the server you’ll find it helpful just to put your passphrase (the local password you chose when encrypted the keys) to the password field of Transmit app. As Transmit app developer recommends here: If you’ve specified an encrypted key for use with this server in your config file, you can leave the key button alone and put the passphrase in Transmit’s password field.

Spent some time… Helped me a lot.

Sugarhill thanks for the additional input. Also, for work related large file transfers I’d take a look at Innorix DS.