Question

How to have one url still working in http:// when site is redirecting to https://?

Posted April 2, 2020 175 views
Security

Hello everyone,
I have an email signature forever with an http:// address my site now it is https:// and I would like how to maintain the old address so that my old emails don’t show the image error.

http://www.vitaminak.com.br/logo_email.png [old]
https://www.vitaminak.com.br/logo_email.png [new]

ERROR that happens when gmail try to access it as it is automatically redirect
https://ci4.googleusercontent.com/proxy/L1eVWHeA4YIMweHcs6HyNBd_zVflcHh_-Zr4-CzBNCCMDy0jcx-3wyVPr3TOBAEeIEgUCFUl1Q8wnuGQ_RPvPw=s0-d-e1-ft#http://www.vitaminak.com.br/logo_email.png

Is there any configuration that I could do to solve this problem?

Thank you in advance for your help!

Cheers,
Karla

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hi there @karlafernandes,

I could suggest either:

  • Changing your email signature to actually use HTTPS URL so that you don’t have to make any changes for your Apache webserver

  • Make sure that your website is actually accessible via HTTP as well as HTTPS. At the moment if you visit your site via HTTP you would get a 403 error.

If you decide to go for option 2, you would need to make sure that your Apache Vhost for port 80 is configured correctly. If you wish you could share your Apache Virtual Hosts for port 80 and 443 here so that I could try to advise you further.

Hope that this helps!
Regards,
Bobby

Well, Bobby, I am already using https:// for the new ones but I don’t want my old emails to have a missing image as I explained.

My links are being redirected all to https automatically.

Is there a way to add this kind of exception?
How do I get away with the cache from my website on the server using apache2?

Thanks!
Karla

Submit an Answer