How to install mod_mono on Ubuntu 14.04 droplet

January 16, 2015 2.9k views

Hi, I'm trying to install mod_mono for Apache, but when I try to install the module libapache2-mod-mono I get:

The following packages have unmet dependencies:
 libapache2-mod-mono : Depends: apache2.2-common but it is not installable

When I try to install the dependency apache2.2-common I get:

Package apache2.2-common is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  apache2-bin:i386 apache2:i386 apache2-data apache2-bin apache2

E: Package 'apache2.2-common' has no installation candidate

I want to use Apache for running a Mono web application.
Has anybody been able to install Apache's mono_mod on an Ubuntu droplet?


1 comment
  • While we don't yet have a tutorial that addresses this, Ubuntu has some documentation available here. According to that it is important to ensure that you enable the universe repository in your apt sources.list and run an apt-get update before installing libapache2-mod-mono.

2 Answers

I have same problem, What version of apache do you have?, Because apache2.2-common, it's for Apache2.2.22, when yo do "sudo apt-get update", then, "sudo apt-get install apache2", Apache2.4.7 is installed, you need Apache2.2.22 version, to install apache2.2-common.

I downloaded Apache2.2.22 package from, and I installed all the dependencies, something like this:

  • libapr1 (1.4.6-1)
  • libdb5.1 (5.1.25-11build1)
  • libaprutil1 (1.3.12+dfsg-3)
  • libaprutil1-dbd-sqlite2 (1.3.12+dfsg-3)
  • mysql-common (5.5.44-0ubuntu0.12.04.1)
  • libmysqlclient18 (5.5.44-0ubuntu0.12.04.1)
  • libaprutil-dbd-mysql (1.3.12+dfsg-3)
  • libodbc1 (2.2.14p2-5ubuntu3)
  • Installed with apt-get: odbcinst1debian2.
  • Installed with apt-get: odbcinst
  • Installed with apt-get: unixodbc
  • libaprutil1 (1.3.12+dfsg-3)
  • libaprutil1-dbd-pgsql (1.3.12-dfsg-3)
  • libaprutil1-dbd-odbc (1.3.12-dfsg-3)
  • freetds-common (0.91.1)
  • libsybdb5 (0.91.1)
  • libaprutil1-dbd-freetds (1.3.12+dfsg-3)
  • libaprutil1-ldap (1.3.12+dfsg-3)
  • Uninstall: sudo apt-get autoremove apache2.2-bin
  • libaprutil1 (1.3.12+dfsg-3)
  • libaprutil1-ldap (1.3.12-dfsg-3)
  • apache2.2-bin (2.2.22-1ubuntu1.10)
  • apache2-utils (2.2.22-1ubuntu1.10)
  • apache2.2-common (2.2.22-1ubuntu1.10)
  • apache2-mpm-worker (2.2.22-1ubuntu1.10)
  • apache2 (2.2.22-1ubuntu1.10)

At the last yo install apache2.2.22, were installed some packages repeatedly, because the dependencies and some package uninstalled.

With all this I solve de dependecie from libapache2-mod-mono.

I hope this help!

Thanks, I already solved the problem using this link:
Install Mono on Linux

It directs to add a second repository ("mod_mono (Ubuntu 13.10 and later, Debian 8.0 and later)"), so it can be installed with Apache 2.4.

Have another answer? Share your knowledge.