How to install php7.0-fpm on Ubuntu 18.04 server

October 20, 2018 11.3k views
PHP Ubuntu 18.04

I have a laravel app that works perfectly with php 7.0. But on 7.2 many features are not working. So I would like to remove 7.2 from my server and install 7.0.

I could only find this command in the help

sudo apt-install php7.0-fpm

but when I run this I get the following error.

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php7.0-fpm
E: Couldn't find any package by glob 'php7.0-fpm'
E: Couldn't find any package by regex 'php7.0-fpm'

What can I do to solve this problem.

3 comments
1 Answer

I tried following the steps to get the latest version working, but ran into issues with the first line
sudo apt-get install python-software-properties

I get

Package python-software-properties is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
software-properties-common

I come from this guide, and the fourth step

The php-xml and php-mbstring packages installed on your server. Install these by running: sudo apt-get install php7.0-mbstring php7.0-xml.

is running into this error

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php7.0-mbstring
E: Couldn't find any package by glob 'php7.0-mbstring'
E: Couldn't find any package by regex 'php7.0-mbstring'

Granted, I haven't installed Nginx, but am using Apache instead. Is that what's causing this headache? Because I can't seem to find any answers out there.

by András Magyar
By following this tutorial, you will deploy a Laravel application automatically without any downtime. To do this, you will prepare the local development environment from which you'll deploy code and then configure a production server with Nginx and a MySQL database to serve the application.
Have another answer? Share your knowledge.