How to install Python requirements with serverless function?

I tried everything in This question

I can’t get the virtual environment to use the installed packages.

using virtualenv yielded a “command not found” error

the following .sh file will run and ostensibly install the packages when running doctl serverless deploy

set -e
#virtualenv virtualenv
python3 -m venv virtualenv
source virtualenv/bin/activate
sudo pip3 install -r requirements.txt --target virtualenv/lib/python3.9/site-packages

but getting “No module found” errors at runtime.

Documentation for functions is lackluster at best. How can it be so difficult to simply install requirements?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Matt Welke
DigitalOcean Employee
DigitalOcean Employee badge
February 13, 2023

the following .sh file

The answer from my colleague that you linked is the correct approach, but I do notice that it’s a bit out of date. We now recommend customers exclude dependencies like pip from the virtual env.

Check out for an example. Note the file in particular.

Documentation for functions is lackluster at best.

We have heard feedback that it could use more information. We’re working on updates right now. Feel free to give feedback about docs using our official feedback platform too (

Regarding the function you’re trying to deploy here, feel free to respond here or open a support ticket if it’s still not working for you after following the example I linked.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up