How to manage certificate signing requests with the Kubernetes API

As I was following this documantation I got this error:

error: resource mapping not found for name: “testuser-authentication” namespace: “” from “STDIN”: no matches for kind “CertificateSigningRequest” in version “” ensure CRDs are installed first

When I tried this script:

cat <<EOF | kubectl apply -f -
kind: CertificateSigningRequest
  name: testuser-authentication
  - system:authenticated
  request: $(cat ~/certs/testuser.csr | base64 | tr -d '\n')
  - digital signature
  - key encipherment
  - server auth
  - client auth

that I took from the docmunation from “Managing Certificate Signing Requests with the Kubernetes API” character.

Please help to solve the problem

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I solved the issue by channging this:


to this;


Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up