Question

how to modify Apache to Allow URL Rewrites?

  • Posted on January 23, 2015
  • elearnAsked by elearn

I want to Configure Pretty Permalinks for WordPress according to https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-on-ubuntu-14-04.

when to sudo nano /etc/apache2/sites-available/000-default.conf

1.There is no 000-default.conf in default? 2.how to fill it ?

  1. my wordpress address is bulid on http://noxp.info/wp/ where is the ServerName ?
  2. how to fill the file?Is the following format right?

<VirtualHost *:80> ServerAdmin webmaster@localhost DocumentRoot /var/www/html ServerName server_domain_name_or_IP <Directory /var/www/html/> AllowOverride All </Directory> </VirtualHost *:80>

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

root@change:~# ls /etc/apache2/sites-available/ default default-ssl

root@change:~# cat /etc/apache2/sites-available/default <VirtualHost *:80> ServerAdmin webmaster@localhost

    DocumentRoot /var/www
    <Directory />
            Options FollowSymLinks
            AllowOverride None
    </Directory>
    <Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
            AllowOverride None
            Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
            Order allow,deny
            Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

I have tested to change “AllowOverride None” into “AllowOverride All” in the file " /etc/apache2/sites-available/default" and set permalinks in wordpress setting to post name and input the command : sudo a2enmod rewrite sudo service apache2 restart

done!

There is the last problem remain here: What is the different betwwen them : /etc/apache2/sites-available/default and /etc/apache2/sites-available/default-ssl?