Question

How to push image to private docker registry

It’s not a question. I don’t know where I can post this tip

Today I tried to setup private docker registry on Ubuntu 14.04

Everything goes fine. I tried to build one docker image and tag Next, I tried to push this image to private docker registry but I always receive “tls: oversized record received with length 20527”

I tried to search on google and changed /etc/default/docker (add --insecure-registry)


–insecure-registry hostname.goes.here:5000 –insecure-registry http://hostname.goes.here:5000

it fails. If I change to: –insecure-registry=hostname.goes.here:5000

It works.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You will receive that error message either when when attempting to connect to a TLS (secure) socket without using TLS or attempting to connect to a non-TLS secured socket with TLS.

The configuration in /etc/default/docker may not be sourced in certain situations. It is an implementation detail of the init system (e.g. newer version of Ubuntu with systemd will not use this file). The best approach is to use Dockers own configuration files.

In /etc/docker/daemon.json, set:

{
  "insecure-registries" : ["example.com:5000"]
}

For more info (and the requisite warnings about using an insecure registry), see: https://docs.docker.com/registry/insecure/