How to redirect to HTTP after removing the Letsencrypt

September 24, 2017 1.1k views
Let's Encrypt Ubuntu 16.04

Hello friends,

I installed correctly a letsencrypt, but as my script had not supported for https://I removed a letsencrypt, but now the site is not doing the redirect to http://
I have many pages indexed on Google but when accessing as https://seems blank I want to do redirection to http://

Using digitalocean, Serverpilot, Ubuntu 16/04
When using https://videoonlinegratis.com.br1 the error I want Use only http://videoonlinegratis.com.br

Inside the file / videoonlinegratis.conf

server {
listen 80;
listen [::]:80;
server_name
videoonlinegratis.com.br
www.videoonlinegratis.com.br

root /srv/users/serverpilot/apps/videoonlinegratis/public;

access_log  /srv/users/serverpilot/log/videoonlinegratis/videoonlinegratis_nginx.access.log  main;
error_log  /srv/users/serverpilot/log/videoonlinegratis/videoonlinegratis_nginx.error.log;

proxy_set_header    Host              $host;
proxy_set_header    X-Real-IP         $remote_addr;
proxy_set_header    X-Forwarded-For   $proxy_add_x_forwarded_for;

include /etc/nginx-sp/vhosts.d/videoonlinegratis.d/*.nonssl_conf;
include /etc/nginx-sp/vhosts.d/videoonlinegratis.d/*.conf;

I have several pages indexed on Google with https://, but I can not redirect to http://

Somebody help me please

Sorry about the English.

edited by asb
1 Answer

Hello,

What I could suggest here is leaving your Let’s Encrypt enabled so that you could then redirect the https traffic to http. You can then use this server block to do the https to http redirect:

server {
       listen 443;
       server_name yourdomain.com www.yourdomain.com;
       rewrite ^(.*) http://$host$1 permanent;
 }

Note that if you delete the SSL certificate you would not be able to do the redirect.

Hope that this helps.
Regards,
Bobby

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!