Hi there.

I’m using Spaces for pictures storage for my website. I’ve uploaded 7 mil pictures.

How can I setup permissions for all at once to public so I can access them for my website?
I see that there is no option on cloud Spaces page. Can i do it with FileZilla?

Thanks in advance for your urgent help!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hello, @alexneacsu

A quick solution to this should be use the build-in File Permissions function in FileZilla. You need to enter the desired directory and then select all files (Ctrl +A) and then right click and select the File Permissions option. A new window will open where you can set the file attributes and set the desired file permissions.

You can also check this page from our official docs:

https://www.digitalocean.com/docs/spaces/how-to/file-permissions/

Also you can install and configure s3cmd and run the following command:

s3cmd setacl s3://spaces/directory/path/ –acl-public –recursive –verbose

This can also be scripted in order to make each uploaded file PUBLIC by default.

Let me know how it goes.

Regards
Alex

Hi there Alex.

I’ve asked my developer to follow your instructions and we get this error:

Georgiana@WinSrv-1 MINGW64 /c/s3cmd
$ python  s3cmd setacl s3://europiesa/webp -acl-public -recursive -verbose
s3cmd:308: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if response["status"] is 200:
s3cmd:310: SyntaxWarning: "is" with a literal. Did you mean "=="?
  elif response["status"] is 204:
Usage: s3cmd [options] COMMAND [parameters]

s3cmd: error: no such option: -a

Can you please help me more?

Thanks in advance!

Regards,
The other Alex

edited by MattIPv4

Looks like you need to enter double dashes as is linux’s practice when using full word parameters
e.g. –acl-publc –recursive –verbose.

You can safely ignore the syntaxwarnings.

Submit an Answer