Question

How to set timeout to 0 in Redis Managed Database?

Hi,

With using redis-cli, setting the timeout to 0 is as simple as running the command config set timeout 0. However, trying to do the same in Redli gives error. Is it possible to manually set this timeout in a DO Redis Managed Database?

Best regards,


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @dekev

We set timeout value to 300 seconds by default for Redis Managed database. This is configurable parameter. If you would like to have the timeout modified, just let us know the desired value (valid values are from 0 (disable) to 60 * 60 * 24 * 365 seconds) by opening the support ticket. We would modify the timeout value as per the request in support ticket.

Regards, Priyanka

As of at least 2022-04-13, this is now possible through the API. Here’s a relevant support response:

Our engineering team has made an update to change database configuration on the managed database cluster. You should now be able to change cluster configuration via API.

For your reference, you can follow the below document on API :

https://docs.digitalocean.com/reference/api/api-reference/#operation/patch_database_config

How to create a personal access token :

https://docs.digitalocean.com/reference/api/create-personal-access-token/

(Just figured I would post an updated answer here, because this is the first Google result for me)

Cheers!