Question

How to set up DNS "masking" for an entire website (Wordpress)

Hello,

I registered a domain name through Google domains, and I forwarded the domain name (proper nameservers for DO to Google and all). But I still have a major problem.

When one visits the website (www.kathyehoward.com, for example) they are greeted with the home page. But when they click on a link. The IP address shows up in the URL (From www.kathyehoward.com to http://104.236.41.215/2015/06/23/hello-world/).

I want to make http://104.236.41.215/2015/06/23/hello-world/ to http://www.kathyehoward.com/2015/06/23/hello-world/

I don’t know if this is a duplicate question or not, but I wasn’t %100 sure on the terminology for “masking” an IP address, or how to describe it without using examples. I do believe it is an issue with DNS, however.

WHOIS - Domain Name: KATHYEHOWARD.COM Registrar: GOOGLE INC. Sponsoring Registrar IANA ID: 895 Whois Server: whois.rrpproxy.net Referral URL: http://domains.google.com Name Server: NS1.DIGITALOCEAN.COM Name Server: NS2.DIGITALOCEAN.COM Name Server: NS3.DIGITALOCEAN.COM Status: clientTransferProhibited http://www.icann.org/epp#clientTransferProhibited Updated Date: 28-jun-2015 Creation Date: 23-jun-2015 Expiration Date: 23-jun-2016


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Your DNS is probably set up correctly. I am guessing the issue is that when Wordpress was installed, it was using the IP address rather than the domain.

If that is the case, the solution is to go into Wordpress Settings>General and change the site address and the Wordpress address to your domain rather than the IP address.

Click save, and then revisit the site at the domain and see if that fixed it…might need to clear the cache on your browser first.