How to set up passwordless postgresql for deployer user?

December 3, 2014 1.2k views

I'm trying to set up passwordless postgres for my 'deployer' user. Made a couple of changes to pg_hba.conf file and restarted the service.

Here is how my current pg_hba.conf file looks:

### Database administrative login by Unix domain socket
local all postgres peer

### TYPE DATABASE USER ADDRESS METHOD

### "local" is for Unix domain socket connections only
local all all peer
### IPv4 local connections:
host all all 127.0.0.1/32 md5
### IPv6 local connections:
host all all ::1/128 md5 

But even now when I ssh back in as deployer and $ sudo -i -u postgres it asks for the password. Is there something else that I have to do?

1 Answer

In order to allow passwordless login to Postgres, you should change peer to trust:

/etc/postgresql/9.3/main/pg_hba.conf
# Database administrative login by Unix domain socket
local   all             postgres                                trust

Remember to restart Postgres so the change takes effect: sudo service postgresql restart

From the Postgres docs:

When trust authentication is specified, PostgreSQL assumes that anyone who can connect to the server is authorized to access the database with whatever database user name they specify (even superuser names). Of course, restrictions made in the database and user columns still apply. This method should only be used when there is adequate operating-system-level protection on connections to the server.

Another option that is a bit more restrictive would be to create a .pgpass file in the deploy user's home directory.

Have another answer? Share your knowledge.