Question

How to set up phant.io on my droplet?

  • Posted February 25, 2015

I want to run Phant.io on my droplet.

I installed node.js, I installed npm, I installed phant.

I typed “phant” via ssh. No reaction. I stopped apache with “service apache2 stop” and typed “phant” again. Still, no reaciton. I’m stuck, what can I do?

Subscribe
Share

got it to work. I had to update nodejs from PPA (whatever this means)

sudo add-apt-repository ppa:chris-lea/node.js  
sudo apt-get update  
sudo apt-get install nodejs

Yes. So I reinstalled to make sure I set the flag global. When reeinstalling I found this line:

npm WARN engine wez-telnet@0.1.1: wanted: {"node":"~0.6.5"} (current: {"node":"v0.10.25","npm":"1.3.10"})
npm WARN engine phant-meta-nedb@3.1.1: wanted: {"node":"^0.10.30"} (current: {"node":"v0.10.25","npm":"1.3.10"})
npm WARN engine phant-stream-csv@2.1.1: wanted: {"node":"^0.10.30"} (current: {"node":"v0.10.25","npm":"1.3.10"})
npm WARN engine phant-manager-http@4.5.10: wanted: {"node":"^0.10.30"} (current: {"node":"v0.10.25","npm":"1.3.10"})

So, I tried to check my node version with the ssh command: node -v but this doesn’t work in any way either:

root@ProcessingServer:~# sudo node
root@ProcessingServer:~# sudo node -v
root@ProcessingServer:~# node -v
root@ProcessingServer:~# 

I guess I’m doing something elementary wrong here?

You are correct, I apologize for missing that. It does look like the -g flag is required in the install in order for the phant command to be in your path. Did you ensure that the -g flag was used when you did the npm install?

@ryanpq What about this then?

"Now you can start phant:

$ phant
phant http server running on port 8080
phant telnet server running on port 8081

"

This comment has been deleted

Looking over the setup details listed here. There is no mention of using a command directly called phant. The instructions indicate that once you complete these steps you open a browser and navigate to port 8080 or connect via telnet to port 8081.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

This question was answered by @ildr3him:

got it to work. I had to update nodejs from PPA (whatever this means)

sudo add-apt-repository ppa:chris-lea/node.js  
sudo apt-get update  
sudo apt-get install nodejs

View the original comment