Question

How to set up ufw rules for softether vpn?

  • Posted January 21, 2015

http://blog.lincoln.hk/blog/2013/05/17/softether-on-vps-using-local-bridge I set softether referring above link. And I set an L2TP vpn.

My “ifconfig”

eth0 (I replaced my server ip with 1.2.3.4)

Link encap:Ethernet HWaddr fa:16:3e:3c:b0:a0 inet addr:1.2.3.4 Bcast:1.2.3.255 Mask:255.255.254.0 inet6 addr: fe80::f816:3eff:fe3c:b0a0/64 Scope:Link

lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host

tap_soft Link encap:Ethernet HWaddr 00:ac:ab:80:3c:c7 inet addr:10.10.10.10 Bcast:10.255.255.255 Mask:255.0.0.0 inet6 addr: fe80::2ac:abff:fe80:3cc7/64 Scope:Link

My dnsmasq.conf

interface=tap_soft dhcp-range=tap_soft,10.10.10.10,10.10.10.20,12h dhcp-option=tap_soft,3,10.10.10.10

My ufw setup

ufw default reject incoming ufw default allow outgoing ufw allow 500/udp ufw allow 4500/udp ufw allow 1701

I can’t connect to L2TP when I enable ufw. But it’s ok when ufw disabled.

Thanks!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You may try settings from here

most important is turn on ipv4 frowarding and NAT.

I haven’t try this myself, let me know if that works.

bests.