Question

How to setup a SSL certificate from ClouDNS

Posted January 7, 2020 601 views
WordPress

Hi. I have a Ubuntu OpenLiteSpeed Wordpress droplet, but my domain is hosted elsewhere (ClouDNS) … I made all the arrangements so my domain works with my droplet, but I cannot use the CLOUDNS SSL certificate that I bought for my domain.

I know there is a guide in here that teaches us how to do that, but I couldn’t follow it up. So can someone explain me. step-by-step how to make setup it?

Thank you!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

Hello, @rodrigocapital

I assume you’ve followed this tutorial: https://openlitespeed.org/kb/ssl-setup

Could you please let me know if this is the guide you’ve followed and which step/part of the process is not clear to you so I can try to explain this for you?

The SSL installation itself is not a complicated process, but can be confusing if you’ve not done it before. This process involves adding a few SSL-related lines to your web server software configuration.

Looking forward to hearing from you.

Regards,
Alex

Hello, @rodrigocapital

What happens if you try to access it using your IP address but with https as well? Basically like this:

https://IPaddr:7080

If this is still not working can you please let me know if you’re getting any error messages in your browser or if you can track any logs in the server logs as well?

Let me know how it goes.

Regards,
Alex

Hello, @rodrigocapital

Can you confirm if the web server is running fine? You can check this via ssh using netstat

netstat -plunta | grep 80

and

netstat -plunta | grep 443

Let me know what’s the output of this.

Regards,
Alex

Hello, @rodrigocapital

Your droplet is running out of memory and the process killer have killed the mysql service in order to prevent further issues. May I ask if you expect a lot of mysql queries for your site?

Regards,
Alex

  • really? how come. I only use wordpress.
    Should I upgrade my server?

    • Once server up again, please try command

      ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head
      

      to show which process spend the most memory from server.

      • “ps -eo pid,ppid,cmd,%mem,%cpu –sort=-%mem | head”

        I tried this command but nothing happens

        • Hello, @rodrigocapital

          It looks like the format is wrong, instead of using two dashes you’ve used –

          The correct syntax is:

          ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head
          

          You can try to enter it manually if you’re still experiencing any issues to execute it on your droplet.

          Regards,
          Alex

    • Hello, @rodrigocapital

      I will recommend you to access your droplet and examine the memory usage it details. If you’re enable to ssh to droplet you can reboot it from the control panel or access the console as well.

      You can use top / htop to display the processes running on your droplet. You can also use the command provided by @eleu

      ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head
      

      You will probably see that /usr/sbin/mysqld is consuming most of the memory on your server.

      If you’re expecting a lot of traffic to your websites MySQL might be busy doing some queries which can cause issues like this one. You can consider to upgrade your droplet as this is very likely to solve the issues for you.

      However if you do not expect big traffic to your sites then you can monitor the MySQL performance for any sleeping queries and etc. You can inspect the MySQL queries using mysqladmin proc directly from your terminal, when not busy it should return the following output:

      mysqladmin proc
      +--------+------+-----------+----+---------+------+----------+------------------+
      | Id     | User | Host      | db | Command | Time | State    | Info             |
      +--------+------+-----------+----+---------+------+----------+------------------+
      | 126269 | root | localhost |    | Query   | 0    | starting | show processlist |
      +--------+------+-----------+----+---------+------+----------+------------------+
      

      In order to monitor it in almost real time you can use:

      watch -n 0.3 mysqladmin proc
      

      Another way is to access the mysql console:

      mysql
      

      and then type show full processlist:

      mysql> show full processlist;
      

      Hope this helps

      Regards,
      Alex

  • Hi, so I finally accessed myip:7080, but when I try to create the “listener” I dont have the files “.pem” and I cannot find them on my server (via FTP)

    All I have right now are the files cloudns provided me (4 fils .csr)

    I really don’t know what to do now.
    (i tried a few things up, light setting up nginx but it broke my website completely)

    Can you explain me step-by-step what should I do.

    Imagine I’ve just bought the cloudns SSL. What do I do now? Thank you.

    • HI,

      Okay, there are port 80/443 on listeners created by default, so you don’t really need to create a new one. Just need to

      1. Copy your certificate to the server from cloudns
      2. Check the certificate key,pem or cert file path
      3. Add the file path to the port 443 listener > SSL tab from web admin at port 7080

      It probably you are pointing to a non-exist file if you saw ‘I dont have the files’.

      Welcome to join LiteSpeed Community on Slack if you need to get more support directly.

      Best,
      Eric

        1. Copy your certificate to the server from cloudns:

        Ok, I have done it. There are 4 files from Cloudns on /etc: AddTrustExternalCARoot.crt, capitalinformacaocombr.crt, SectigoRSADomainValidationSecureServerCA.crt, USERTrust, RSAAddTrustCA.crt.

        1. Check the certificate key,pem or cert file path:

        I can’t find it, where is it supppose to be? can I generate it again? I’m stuck at this part.

        Thank you!

Hi, a did everything I read here and in the tutorials, but I still unable to install the SSL Certificate.

Please, could you help me to do so.

I have a paid certificate with Cloudns, but I would use Let’s Encrypt if it means I will be able to setup it in a easier way.

Thank you!

Submit an Answer