How to setup an SRV record on the latest Digital Ocean Interface?

Ok so I’ve read all 10 or so topics regarding the configuration of srv records here on digital ocean but they’re all seem outdated.

I’m trying to setup an srv record for a minecraft server.

I know how to set them up since I’ve had this minecraft server for a while and and the srv record was working just fine on my previous host provider but I can’t seem to get it to work with digital ocean.

Here’s the previous working configuration I had and that it shows up on most srv configuration tutorials on google:

an A Record pointing to server’s ip (minecraft server) example:

and the SRV pointing to that same A Record as such:

Host: Points to: port: 10041code Priority: 0 Weight: 5

Should be accessible through

That seems logical and it works, but not on Digital Ocean, here is what I get when I try those same settings:

apparenty for some odd reason it won’t take the already known to work but it will take _minecraft._tcp (without an specified subdomain) as seen on the next screenshot:

Then, I thougt, maybe in this new Digital Ocean Interface I don’t need to specify the subdomain directly into the hostname and all I have to do is point it to the A record, so I tried:

Digital Ocean seems to take that configuration but it just won’t work.

The is reachable since it does exists as an A record but the srv configuration just won’t kick in.

I’ve tried every single possible combination to no avail.

Anyone knows how to get an srv record working on the most recent Digital Ocean’s interface?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Just learned that if you put a “.” period after the domain name it will not append the domain name. Thanks DO!!!

Since I couldn’t wait until this problem got resolved I had to leave Digital Ocean and ended up finding a better deal but for everyone else having the same issue, simply handle your dns through your domain provider or cloudflare, srv records work great on both, cloudflare, not so good for enjin though.

I have the same problem.