Question

How to solve problems with LAMP Webserver

I have been following the tutorial to setup LAMP on my server: https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-ubuntu-14-04 I have also setup my domain with DigitalOcean nameservers, A record & CNAME record.

When I visit my public IP address or my domain name I always get “This page can’t be displayed” - I never managed to get any kind of Apache “It Works” page, or to access any php pages I created at /var/www/html/index.php

Is there any way I can find out what’s gone wrong?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have found that the firewall was causing the problem - fixed now!

Hello dominicduffin,

You could start with reading logs and checking configurations. What does the apache log give you for output when this happens? /var/log/apache2/

What kind of virtualhost did you setup? What did you put inside the php file, try to use a simple .html file instead and check if that works.