We constantly keep bumping into Too Many Clients issue on our Managed Postgresql cluster. We are currently using the smallest cluster.

When we bump into this issue, we try to run pg_stat_activity and kill some pids that are locking it.

But sometimes, we are unable to run the pg_stat_activity command, because of too many connections.

how do we solve this problem for ourselves?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer


What I could suggest is setting up a connection pool for your cluster, it would help you with your max connection limits problem. You can take a look at the official documentation here on how to manage connection pools for PostgreSQL Database Clusters: