Question

How to stop show de default page Nginx?

  • Posted April 22, 2016
  • Nginx

I setup a nginx server, but when I stop or uninstall it, always keeps showing the home page default. Like being in cache. Even with the Droplet off, if you enter the ip browser opens the default page.

I would stop when the server does not show this page

Subscribe
Share

What happens when you visit the IP address from another browser, or from another computer?

Thank you.

I’m not using any cache. And already I wiped my browser’s cache several times and still shows the ngnix page.

I deleted the droplet and yet, when I type the IP, the same thing happens!

Are you using eg. CloudFlare? CloudFlare offers caching which shows your site even when your server is offline or not reachable for some reasons. If not, it’s probably your own cache. Have you tried to clear your cache?

You could just remove or clear the content of the default index.html from your webroot. After that it should show you an empty page, a 403 or the directory listing. Depends on your configuration.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello,

Technically speaking once the Droplet is off or deleted, you should no longer be able to access the IP over HTTP as there is no webservice available to handle the traffic.

Can you verify that you’ve stopped the correct Droplet and that there is no typo in the IP that you are visiting?

Additionally, in case that you have a domain name and you want to disable the Nginx default page, you can do removing the index.html file from the /var/www/html directory and also adding a new server block and deleting the default one as described here:

https://www.digitalocean.com/community/tutorials/how-to-set-up-nginx-server-blocks-virtual-hosts-on-ubuntu-16-04

Best,

Bobby

This comment has been deleted