How to switch PHP version of the WordPress marketplace app to 7.4?

The current version of the Wordpress marketplace app is shipped with PHP v8:

How can I configure it to use PHP v7.4 instead?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello, @plantslovertbilisi

As per Bobby’s comment, the active support for PHP 7.4 would end by the end of the year which you should take under consideration.

You can also spin up a Ubuntu or CentOS droplet and then install PHP 7.4 (configure the LAMP stack) as per your wish.

And then install WordPress manually as per this tutorial:

However, if you’ve already used the marketplace app you should follow the instructions provided by Bobby.

Regards, Alex


Just as a side note, the active support for PHP 7.4 would end by the end of the year as per the PHP official website here:

In case that you still would like to downgrade the PHP version from 8.0 to 7.4, you could do it by running the following commands:

Make sure to take a snapshot of your server before proceeding. That way in case anything goes wrong, you would be able to revert back to a working state of your website!

  • Update your repositories:
sudo apt update
  • Install PHP 7.4 along with all of the required PHP modules:
sudo apt install php7.4 php7.4-cli php7.4-mysql php7.4-curl php7.4-gd php7.4-mbstring php7.4-xml php7.4-xmlrpc php7.4-soap php7.4-intl php7.4-zip libapache2-mod-php7.4 php7.4-common php7.4-json php7.4-opcache php7.4-readline
  • Disable the PHP 8 Apache2 module:
a2dismod php8.0
  • Enable the PHP 7.4 Apache module:
a2enmod php7.4 
  • Finally, restart Apache so it could load the new PHP 7.4 module:
systemctl restart apache2

Hope that this helps. Best, Bobby