Question

How to troubleshoot x session issue

Hi! I’m new to Linux, I’m running a Ubuntu 12.10 x64 desktop, was on 512MB RAM. I installed a vncserver and was able to use tightvnc viewer to login remotely, but quickly run out of RAM after installed wordpress. I upgraded droplet to a 2GB RAM, when I access tightvnc, I can’t login any more, get connection refused message. I’m not sure where went wrong, how to fix this issue… Please help!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks for reply, much appreciated! <br> <br>Yes, the virtual server seems very memory hogging. <br>Now I have 2GB RAM, LAMP+WP, vnc on it, over 1quarter RAM already gone, <br>not sure how long RAM would last, to simply run a picture-riched blog. <br> <br>I’m running VNC only to use browser there to gain full internet access. <br>How do I know how many display I already run for vncserver? <br>I run vncserver -kill :1, get following result: <br>Can’t find file /home/username/.vnc/hostname:1.pid <br>You’ll have to kill the Xtightvnc process manually <br>Does this mean there is no session open at this time? <br> <br>I think 2 times I didn’t close properly, one time I couldn’t login remotely, so 2nd time I run from web console, <br>but resolution too big for web console screen, can’t see anything, have to reboot… shoot me! <br> <br>When I say I can’t login, I’m using tightvnc viwer on Mac to login remotely to ip_address:5901 <br>When click “connect” on tightvnc-viewer.jar, it give error: couldn’t connect to ip@:5901, connection refused. <br>There is no hint what cause the problem, as I can login before a few times,
<br>now I increased RAM and copied image from old droplet, password remains the same. <br>It could be crashed due to previous insufficient memory, but I don’t know how to recover. <br> <br>In /tmp, I delete everything including hidden file, but I still can’t login from tight-vncviewer.jar, same error message <br>How to remove everything and re-install? Would it be faster? <br>/tmp: <br>-rw------- 1 vnc vnc 418 Mar 22 09:09 .xfsm-ICE-Y77UCX <br>-r–r–r-- 1 vnc vnc 11 Mar 22 09:09 .X1-lock <br>drwxrwxrwt 2 root root 4096 Mar 22 09:09 .X11-unix <br>-r–r–r-- 1 root root 11 Mar 22 09:09 .X0-lock <br>drwx------ 2 vnc vnc 4096 Mar 22 09:09 ssh-Xyc6JXFzXGM8 <br>drwx------ 2 vnc vnc 4096 Mar 22 09:09 pulse-PKdhtXMmr18n

To stop a vnc <br>vncserver -kill :# <br>where # is a number, incrementing every time you run the vncserver command. Each number represents a virtual display and each has its own session. <br>__ <br> <br>I would recommend against a vncserver on the droplet, because of the amount of resources it takes to run the desktop environment. Plus, if you forget to terminate the vncserver when you’re done, it will just hog more resources, wasting RAM. Not having a vncserver will also save you disk space, but hey - it’s your server, not mine. <br> <br>I recommend doing everything remotely. Don’t setup wordpress from the browser on your droplet. Don’t even install a browser on your droplet. Do that from your computer instead. Use FTP/sFTP to transfer files between your computer and the server Filezilla is great for this. Use SSH to access the terminal. PuTTY is great for this. If you have a webserver running on your droplet, you can access it just like a website. In your browser’s address bar, put the IP address of your server. <br> <br>The more unnecessary stuff you install on your server, the more resources you waste and the more possible security holes you open. <br>__ <br> <br>Now that that’s out of the way, can you please clarify what you mean by “I can’t login” <br> <br>SSH: you can access an emergency terminal from your Digital Ocean control panel <br> <br>TightVNC: This usually means the VNCserver crashed, or Linux ran out of ram and pkilled your VNCserver to free up RAM. <br>You’ll have to restart the VNCServer to access it again. In this case there are usually some temp files you have to remove because the VNCServer crashed before it got a chance to remove them. Without removing them, the next time you start VNCServer it will think a virtual display is already open, so it will open on the next available spot (incrementing 1). <br> <br>Most likely your problem is the “TightVNC” one. <br> <br> <br>For installing Wordpress, you have 2 options. <br> <br>1: Install manually. A detailed guide is here: <br>https://www.digitalocean.com/community/articles/how-to-install-wordpress-on-ubuntu-12-04 <br> <br>2: Install a droplet with Wordpress already installed. If you just installed your droplet, I would use this option. This is the fastest option. <br>https://www.digitalocean.com/community/articles/one-click-install-wordpress-on-ubuntu-13-10-with-digitalocean