How to turn off docker caching in App Platform?
I have a problem with deploying static site, and it feel like it’s not using my updated Dockerfile.

1 comment
  • I’m having the same issue. If I added a new dependency to my project .net 5.0 project (using nuget), it doesn’t pick it up. I don’t get any errors in the console, and the only way I could fix it was by deleting my app and recreating it. I’ll try renaming the component next time.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

👋🏼 @MihkelL

Unfortunately it isn’t possible to disable caching. We are considering adding some form of control over that, but it’s not available yet.

You can manually invalidate the cache by renaming the component, but I’d also like to understand why it is not using the updated Dockerfile. Would you mind opening a support ticket so that can we look into this more closely? Any more details about what’s missing from the build would be appreciated.