How to update and upgrade from ubuntu 14 to ubuntu 18?

December 19, 2018 1k views
Apache

I want update and upgrade my droplet which is on 14 to ubuntu 18 but it is failling and getting this error
W: Failed to fetch https://packages.sury.org/php/dists/trusty/main/binary-amd64/Packages HttpError404

W: Failed to fetch https://packages.sury.org/php/dists/trusty/main/binary-i386/Packages HttpError404

E: Some index files failed to download. They have been ignored, or old ones used instead.

1 Answer

Hey friend,

You can remove that repository, which it seems had been added in on this server. This command will do that:

add-apt-repository --remove ppa:ondrej/php

That said, I highly recommend that you not upgrade this droplet. You have custom packages installed on what I’m guessing is a production system. Something is going to break. You might find that it makes more sense to create a new Ubuntu 18 droplet and migrate to it.

Jarland

Have another answer? Share your knowledge.