Question

how to update code-server on code-server dropplet?

Current code-server OneClick dropplet has code-server v3.0.2 Code-server v3.1.1 is available What would be the procedure to update? I assume there is more to do than just copying the updated source to /usr/local/lib/code-server.

thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Jérome, Did you also touch /tmp? Do you have any logs? (ie see anything interesting in systemctl status code-server when trying to updagrade) For inspiration, check the issue and the comments https://github.com/cdr/code-server/issues/1532 . That’s what directed me to updating auths.

Hi!

I have the same issue to update from 3.1.1 to 3.2.0.

I keep getting the push notification, when I click it says it has updated to 3.2.0 but then after a few seconds I get the same notification again. After checking in the terminal, I’m still on 3.1.1

I installed code server manually by dropping the files in /usr/local/lib and making a symbolic link in /usr/local/bin, and registered it as a service.

I tried to change permissions for /usr/local/lib/code-server, it still doesn’t work…

Thank for your help.

Managed to get it working, I’ll attempt to answer my own question :-)

3.2.0 update is now available and a prompt in the browser should ask you to update. If you simply click it, it will attempt, might tell you it’s been successful but probably fail.

As auto-updates are enabled by default, the issue seems to be related to /usr/lobal/lib authorisation. chmod the folder or change the coder user/group permissions (/tmp might also need a check).

Update via Browser prompt worked.

in 3.2.0 there’s also a change to the host / port binds which stopped me accessing the site. From the release note: “Deprecate --host and --port in favor of --bind-addr which takes the form host:port. For example: --bind-addr localhost:8080.”. So I updated /usr/local/bin/code-server to read : PASSWORD=$(cat /etc/code-server/pass) /usr/local/lib/code-server/code-server --cert --bind-addr 0.0.0.0:8080

Restarted code-server & service… voila.