Question

How to upgrade cURL in Centos6?

All my droplets run Centos 6, and I use cURL quite widely. However, as I’m updating servers to use HTTPS (and, more importantly, restricting to TLSv1) I’ve hit a problem - the version of cURL installed on them all is prehistoric; it’s so old it doesn’t recognise TLSv1.

From comments on fora, this seems to be common, but a solution isn’t. Yum refuses to see a problem as there evidently isn’t a distro in any of the standard repos more modern that v7.19.7. Attempting to upgrade directly with RPM by pulling down a file from e.g. the city-fan repo fails as it triggers a wave of dependency issues that I’m afraid I have no idea how to solve.

It seems bizarre that there isn’t a Yum repo somewhere which has rolled up a more modern distro with all its dependencies, given how critical SSL security has become to almost all websites and how popular Centos6/RHEL is, but I’m buggered if I can find one.

Does anyone know of a suitable repo? If not, can anyone point me towards any decent advice on solving all the dependency problems (everything I’ve googled seems to end with “…and now rebuild cURL” :/)

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Not sure - looks like you are failing dependency resolution for OpenSSL 1.0.1 but I’m not sure why yum can’t find a repo for that - isn’t it part of the RHEL base? Maybe somebody else can clarify that?

yum install libcurl

—> Package libssh2-devel.x86_64 0:1.8.0-7.0.cf.rhel6 will be installed –> Finished Dependency Resolution Error: Package: libcurl-7.60.0-1.0.cf.rhel6.x86_64 (city-fan.org) Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit) Error: Package: libcurl-7.60.0-1.0.cf.rhel6.x86_64 (city-fan.org) Requires: libcrypto.so.10(libcrypto.so.10)(64bit) Error: Package: libcurl-7.60.0-1.0.cf.rhel6.x86_64 (city-fan.org) Requires: libssl.so.10(libssl.so.10)(64bit) Error: Package: libssh2-1.8.0-7.0.cf.rhel6.x86_64 (city-fan.org) Requires: libcrypto.so.10(libcrypto.so.10)(64bit) Error: Package: curl-7.60.0-1.0.cf.rhel6.x86_64 (city-fan.org) Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

what’s wrong?

Hello Everyone!!!

Hope someone can help me with my problem. We have a server at godaddy with CentOS 6 and install a SSL Certificate in it, but we start having problems with paypal transactions, and at godaddy recomend to update curl version following a procedure where we download a tar file, after configure and install the webpage with the certificate stop working, cause paypal and mercadopago doesn’t allow transactions without ssl certificate.

At command line we start looking for the problem and when we run #yum check or #yum update it throws the next error.

"# yum check There was a problem importing one of the Python modules required to run yum. The error leading to this problem was:

libssh2.so.1: cannot open shared object file: No such file or directory

Please install a package which provides this module, or verify that the module is installed correctly.

It’s possible that the above module doesn’t match the current version of Python, which is: 2.6.6 (r266:84292, Aug 18 2016, 15:13:37) [GCC 4.4.7 20120313 (Red Hat 4.4.7-17)]

If you cannot solve this problem yourself, please go to the yum faq at: http://yum.baseurl.org/wiki/Faq"

i can’t run yum commands but can install rpm, Any suggestion?