How to upgrade PHP version 5.3.3 to 5.3.10 to support Joomla 3.3?

August 18, 2014 20.5k views

I have search but can't find the solution, please advice.

[root@do1 ~]# php -version
PHP 5.3.3 (cli) (built: Aug 6 2014 05:54:27)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with Suhosin v0.9.29, Copyright (c) 2007, by SektionEins GmbH
[root@do1 ~]# cat /etc/release
CentOS release 6.5 (Final)
CentOS release 6.5 (Final)
CentOS release 6.5 (Final)
[root@do1 ~]#

3 Answers

In order to upgrade to a newer version of PHP in CentOS 6, you'll need to enable some external repositories, EPEL and Remi. You can download the repositories' information and enable them with:

rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

You can then upgrade PHP with:

yum upgrade --enablerepo=remi php
  • Thank you very much for awesome solution Andrew SB!
    Please, could you also tell me how "BCMath PHP Extension" ?

    I tried the recommended yum install php-bcmath however I get this:

    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * epel:
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package php-bcmath.x86_64 0:5.3.3-27.el6_5.1 will be installed
    --> Processing Dependency: php-common(x86-64) = 5.3.3-27.el6_5.1 for package: php-bcmath-5.3.3-27.el6_5.1.x86_64
    --> Finished Dependency Resolution
    Error: Package: php-bcmath-5.3.3-27.el6_5.1.x86_64 (updates)
               Requires: php-common(x86-64) = 5.3.3-27.el6_5.1
               Installed: php-common-5.4.32-1.el6.remi.x86_64 (@remi)
                   php-common(x86-64) = 5.4.32-1.el6.remi
               Available: php-common-5.3.3-26.el6.x86_64 (base)
                   php-common(x86-64) = 5.3.3-26.el6
               Available: php-common-5.3.3-27.el6_5.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-27.el6_5
               Available: php-common-5.3.3-27.el6_5.1.x86_64 (updates)
                   php-common(x86-64) = 5.3.3-27.el6_5.1
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

    I also tried to find it with:
    yum search bcmath

    and I got this:

    yum search bcmath
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * epel:
    ============================= N/S Matched: bcmath ==============================
    php-bcmath.x86_64 : A module for PHP applications for using the bcmath library
      Name and summary matches only, use "search all" for everything.

    Thank you very much!!!!
    Really appreciate your help :)

Thanks! Everything instructions followed went breeze! But when I started localhost/phpinfo.ini it is still the same 5.3.3 version. Maybe I'll have to restart my computer.

Hey guys

When I try running the upgrade command I get the following error...

Loaded plugins: fastestmirror, priorities

Error getting repository data for remi, repository not found

I didn't see any errors when running the previous commands.

Any thoughts?

Have another answer? Share your knowledge.