How to use HTTPS with

I’m trying to set up on a Ubuntu system that has an Apache server. I want it to use HTTPS instead of HTTP, but have had no success so far. The server has a valid digital certificate via Certbot. I tried to follow the steps shown at and pass the 443 command line argument to, but attempting to start it causes this error: OSError: [Errno 98] Address already in use Running if the Apache server isn’t running doesn’t cause an error, but it still uses HTTP in spite of listening on port 443.

What should I do next to diagnose this problem?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
March 8, 2023

Hi there,

You can not have two services listening on the same port. If your Apache service is already listening on port 443 with a valid SSL, you will not be able to start your Jam app on the same port.

You should start your app as normal and not on port 443.

An alternative option, would be to use Nginx as described here:

The article uses Django as an example, but the setup will be the same.

Let me know how it goes!



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up