Question

How to use the 1-click Wordpress install with the iOS App?

Hi all,

I wanted a self-hosted Wordpress install, and being a fan of the overall simplicity of DigitalOcean, it being my VPS of choice for a long time, I went for the “1-click Wordpress install”.

I should say, it worked like a charm, and I was up and running very quickly. Kudos!

However, I would also like to have it work with the Wordpress app on my phone. And when I try to add the site, I get an error of the form:

Couldn't connect. Required XML-RPC methods are missing on the server."

I’ve spent some time on this before asking here, having encountered numerous “solutions” on StackOverflow etc that do not work.

So I have to ask a more fundamental question first: is it expected that the app can support the 1-click install? If not, it’s definitely a deal-breaker for me, I don’t want to use the desktop-browser version all the time for creating a new post.

I definitely would like to have DigitalOcean be my one-stop shop for this instead of turning to e.g. Linode, so I hope this confusion gets cleared up.

Much thanks in advance, Agam

P.S. some things I tried:

  • a2disconf block-xmlrpc and restarting Apache
  • Installing php-xml
  • Installing php-xmlrpc
Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @agamb ,

The 1-click app should be perfectly fine and probably not the bottleneck here. It just installs all the files, DB’s etc. so you get wordpress running within seconds. You probably have to take a closer look at firewalls, modules and HTACCESS files to find your issue.

Try going to http://example.com/wordpress/xmlrpc.php, your should see a message saying “XML-RPC server accepts POST requests only.” Let me know if this helps! ~Bjorn