Question

.htaccess wont work in Ubuntu 14.04 Even with mod_rewrite

Posted January 29, 2015 8.3k views

Iv'e tried everything, I enabled rewrite module, messed around with the apache config and still my server will not add the .php extension automatically. It just keeps showing a 404 error.

BTW, I have this setup on a virtual host.

Here’s my Apache config:

<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port th$
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/ce

        ServerName computingessentials.tk
        ServerAlias www.computingessentials.tk

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
         <Directory /var/www/ce/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Require all granted
         </Directory>
        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

And here is my htaccess

   RewriteEngine on

   RewriteRule ^([0-9a-zA-Z-]+)$ $1.php [NC,L]
   RewriteRule ^([0-9a-zA-Z-]+)/$ $1.php [NC,L]

   RewriteRule ^videos/([0-9a-zA-Z-]+)$ videos.php?var=$1 [NC,L]
   RewriteRule ^article/([0-9a-zA-Z-]+)$ article.php?var=$1 [NC,L]
   RewriteRule ^video/([0-9a-zA-Z-]+)$ video.php?var=$1 [NC,L]

For example, there is a page called series.php, which should get replaced to /series but when I go to /series, it says file not found.

And you will not be able to access the server since at the moment I have setup my host files to redirect me to the IP.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Have you restarted Apache after adding AllowOverride All? Are there any errors in its error log?

sudo tail /var/log/apache2/error.log

Also, your htaccess can also be written as follows:

   RewriteEngine on

   RewriteRule ^([0-9a-zA-Z-]+)/?$ $1.php [NC,L]
   RewriteRule ^(videos?|article)/([0-9a-zA-Z-]+)$ $1.php?var=$2 [NC,L]

Fewer rules usually means better performance :)

  • [Thu Jan 29 08:57:57.181881 2015] [negotiation:error] [pid 1199] [client 87.109.38.165:2808] AH00687: Negotiation: discovered file(s) matching request: /var/www/ce/series (None could be negotiated)., referer: http://computingessentials.tk/
    [Thu Jan 29 09:07:13.129598 2015] [negotiation:error] [pid 1201] [client 87.109.38.165:1952] AH00687: Negotiation: discovered file(s) matching request: /var/www/ce/series (None could be negotiated)., referer: http://computingessentials.tk/
    

    This is all I get :(

  • Actually, removing the Options Indexes FollowSymLinks MultiViews magically fixed it, but now I get redirected to my articles.json file when I go to /articles

Removing JUST MultiViews from the Options made it work for me when I had a url like....

domain.com/index/action/ .. I assume it has to do with index/ being a keyword.

http://httpd.apache.org/docs/current/content-negotiation.html

The effect of MultiViews is as follows: if the server receives a request for /some/dir/foo, if /some/dir has MultiViews enabled, and /some/dir/foo does not exist, then the server reads the directory looking for files named foo., and effectively fakes up a type map which names all those files, assigning them the same media types and content-encodings it would have if the client had asked for one of them by name. It then chooses the best match to the client’s requirements.*

Submit an Answer