Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

Hi,
i’ve set up my django app with postgres, gunicorn and nginx, and it was working perfectly for more than a month, yesterday and when i tried to access the website, it gaves me Internal Server Error while i didn’t change anything, so i checked the nginx logs and here are the results :
2023/01/27 14:09:15 [crit] 1094411#1094411: *3723 SSL_do_handshake() failed (SSL: error:0A00006C:SSL routines::bad key share) while SSL handshaking, client: 162.243.141.20, server: 0.0.0.0:443
2023/01/27 16:30:17 [alert] 1124567#1124567: *8 open socket #3 left in connection 4
2023/01/27 16:30:17 [alert] 1124567#1124567: *9 open socket #12 left in connection 5
2023/01/27 16:30:17 [alert] 1124567#1124567: aborting
and i’m not sure if the SSL has something to do with it since i had that error before, but one thing that i actually noticed is that when i checked the status of apache2.service, it says Failed to start The Apache HTTP Server., but i think it’s normal since i’m using nginx right ?, here is what i get :
**×** apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; **enabled**; preset: **enabled**)
Active: **failed** (Result: exit-code) since Sat 2022-11-26 17:00:32 UTC; 2 months 1 day ago
Docs: https://httpd.apache.org/docs/2.4/
CPU: 34ms
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[9000]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[9000]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[9000]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[9000]: no listening sockets available, shutting down
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[9000]: AH00015: Unable to open logs
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[8984]: Action 'start' failed.
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 apachectl[8984]: The Apache error log may have more information.
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 systemd[1]: **apache2.service: Control process exited, code=exited, status=1/FAILURE**
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 systemd[1]: **apache2.service: Failed with result 'exit-code'.**
Nov 26 17:00:32 ubuntu-s-1vcpu-1gb-fra1-01 systemd[1]: **Failed to start The Apache HTTP Server.**
So i tried to check the error logs of apache2 using :
sudo tail -n 2 /var/log/apache2/error.log
but it returns nothing,
btw : nginx and gunicorn status are all active and everything looks good, i tried to restart them but i still get the error.
so can someone please help me with this and let me know what should i do ? i’m a beginner into this and just started learning. thanks and i really appreciate your help.
009fd274aeae48f2bfbda6ef568676
Cloudstream Apk
032f50ee7f7d489db3b05e204fe139
032f50ee7f7d489db3b05e204fe139
Edward Sitarski
ebeecroft
dashan
34bcef38725b4e6eb5224ae028f17e
markatango
gouskova