I was in the process of transferring a friend’s Wordpress site to SSL using LetsEncrypt and have hit a snag. While the URL https://eddieorrell.ca works correctly, using http://eddieorrell.ca forwards to https://exit.

I noticed in the set-up for LetsEncrypt through console, it also reads www.exit as a domain.

Any feedback or direction on how to fix this mis-forwarding would be greatly appreciated!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @seanjoud,

Let’s Encrypt’s certbot service for installing SSL certificates uses your WebService’s configuration files to display the domains on said droplet.

Basically, there is an www.exit domain somewhere in your configuration file. First, you need to see if you are using Apache or Nginx. SSH to the droplet and type in:

nestat -tulpen | grep 80

The above command will show you what service is listening on port 80, either Apache2 or Nginx.

If it’s Nginx, go to

/etc/nginx/sites-enabled

In there you should see the configuration files of your domains. Somewhere inside of it, it says www.exit rather than what it’s supposed to. Here there are two ways to find it. Either grep for the exit string or start opening all files and checking if you can find where this exit is. I’ll show you the first option:

grep -ir exit /etc/nginx/sites-enabled/*

This command will show you where the exit string is contained. Once you know you’ll be able to change it inside the file.

Once you change it, don’t forget to restart Nginx.

If it’s Apache2, go to

/etc/apache2/sites-enabled

You can again follow the advice with the grep command here. Having said that after doing the changes restart apache like so:

service apache2 restart

Once you’ve done one of the above, try running Certbot once again.

Regards,
KFSys