https leads to infinite loading

December 21, 2018 397 views
Apache

Hi,

in this topic I would kindly ask you about your opinion, experience and knowledge. Maybe you can assist me into the right direction.

I am running my Wordpress installation on DigitalOcean and the server is located in Netherlands. My main customers are from Iran. Now, as long as I'm running my website with http my customers from Iran are able to open the website. As soon as I install a SSL and change to https, they are not able to open it. The website will fall into infinite scrolling. But only people from Iran are affected, the rest of users from US or EU don't face this issue. One more thing: If Iranians try to open another website based on https, it will open. So, it's only my website.

These are options I already tried out which couldn't solve my problem:

  • I used different SSL cert providers already such as digicert, letsencrypt and comodo.
  • I used another provider with another website (static html site), too. When you switch to https there, the site can't be opened.
  • I tried 3 different IPs for my Wordpress.

Do you have any idea what can cause this problem? Do you have any further idea what to try or look at?

Summary:

  • http works in Iran for my site
  • https doesn't work in Iran for my site only
  • https of my website opens in other countries, just Iran is affected
1 Answer
unixynet December 26, 2018
Accepted Answer

Your country could be blocking https connections

The government's response has included requiring the use of Iranian email systems, blocking popular webmail services, inhibiting encryption use by disabling VPNs and HTTPS, and banning externally developed security software.

Source: https://en.wikipedia.org/wiki/Internet_censorship_in_Iran

Have another answer? Share your knowledge.