Question

Https version of the site shows the Apache start page

Hi I am having a little problem after using wordpress permalinks, the https version of the site shows the Apache start page. On the http version, the site and all permalinks work fine. I also want to say that without using permalinks, the site on http and https works well. I am using CentOS 8

My site - http://cazzy.store/ My site with https - https://cazzy.store/

My .htaccess

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

My httpd.conf

IncludeOptional conf.d/*.conf
<VirtualHost *:443>
    DocumentRoot "/var/www/wordpress"
    ServerAlias www.example.com
    <Directory "/var/www/wordpress">
        allow from all
        Options None
        Require all granted
    </Directory>
    SSLEngine on
    SSLProtocol +TLSv1.1 +TLSv1.2
    SSLCertificateFile /var/ssls/cazzy_store.crt
    SSLCertificateKeyFile /var/ssls/cazzy.key
    SSLCACertificateFile /var/ssls/cazzy_store.ca-bundle
</VirtualHost>
Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I solved the problem by adding this to my .htaccess file

<IfModule mod_rewrite.c>
  RewriteEngine On
  Options +FollowSymLinks
</IfModule>