Https version of the site shows the Apache start page

Posted April 19, 2021 187 views
CentOSApacheWordPressCentOS 8

Hi I am having a little problem after using wordpress permalinks, the https version of the site shows the Apache start page. On the http version, the site and all permalinks work fine. I also want to say that without using permalinks, the site on http and https works well. I am using CentOS 8

My site -
My site with https -

My .htaccess

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

My httpd.conf

IncludeOptional conf.d/*.conf
<VirtualHost *:443>
    DocumentRoot "/var/www/wordpress"
    <Directory "/var/www/wordpress">
        allow from all
        Options None
        Require all granted
    SSLEngine on
    SSLProtocol +TLSv1.1 +TLSv1.2
    SSLCertificateFile /var/ssls/cazzy_store.crt
    SSLCertificateKeyFile /var/ssls/cazzy.key
    SSLCACertificateFile /var/ssls/
edited by MattIPv4

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer
Show answer This answer has been marked as resolved by fenixx4921.