Question

HTTTP/2, DigitalOcean and Apache

Posted February 18, 2016 4.1k views
UbuntuApacheDigitalOceanLet's Encrypt

I’m sorry if this is a bit of a noobish question, but I want to know if DigitalOcean supports HTTP/2. It it does, do I need to take any steps (other than enabling TLS with Let’s Encrypt) to enable it?

Thanks in advance!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Its not a question if DO supports http/2 but if your server does, which version of Apache are you running? Apache 2.4.17 or later is needed, or Nginx 1.9 or later.

  • I thought that was going to be the case. It’s Apache 2.4.7, so how do I make it use HTTP/2?

    • With that I cannot help you. I use Nginx my self and never looked into how it works with Apache, try Googling, there must be good guides out there, but the only request for http/2 is that your server supports it and that https is enabled.

Submit an Answer