Question

hubot Rocket chat adapter installation problem

Posted October 14, 2016 1.3k views

when i install hubot alwasy get the npm permission issue, i tried NVM and two options on https://docs.npmjs.com/getting-started/fixing-npm-permissions#option-2-change-npms-default-directory-to-another-directory, still couldn’t fix it. Pls help, what should i do? it is been days, just doesn’t seem it can be resolved. hehe

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

It seems like based on the article you linked your best course of action would be:
sudo chown -R $(whoami) $(npm config get prefix)/{lib/node_modules,bin,share}

Also in the future I would recommend using n installable via sudo npm install -g n and you can switch to for example Node 4.5 using n 4.5 I’ve seen a lot of people have permission problems after using nvm. Not to say they haven’t fixed it more recently :)

Submit an Answer