Question

I am having some issues on my playbook result ( It seems like is SSH)

I followed all the steps on digitalocean about install and configured ansible but I am still having some issues here is the debug result:

ansible-playbook deploy_logger_lab.yml -vvvv
PLAY [Deploy to logger servers] *********************************************** 

GATHERING FACTS *************************************************************** 
<172.16.31.69> ESTABLISH CONNECTION FOR USER: ansible
<172.16.27.30> ESTABLISH CONNECTION FOR USER: ansible
<172.16.31.69> REMOTE_MODULE setup
<172.16.27.30> REMOTE_MODULE setup
<172.16.31.69> EXEC ['ssh', '-C', '-tt', '-vvv', '-o', 'ControlMaster=auto', '-o', 'ControlPersist=60s', '-o', 'ControlPath=/root/.ansible/cp/ansible-ssh-%h-%p-%r', '-o', 'Port=22', '-o', 'IdentityFile="/root/credentials/ansible_id_rsa"', '-o', 'KbdInteractiveAuthentication=no', '-o', 'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey', '-o', 'PasswordAuthentication=no', '-o', 'User=ansible', '-o', 'ConnectTimeout=10', '172.16.31.69', "/bin/sh -c 'mkdir -p $HOME/.ansible/tmp/ansible-tmp-1443559407.84-11080996630761 && echo $HOME/.ansible/tmp/ansible-tmp-1443559407.84-11080996630761'"]
<172.16.27.30> EXEC ['ssh', '-C', '-tt', '-vvv', '-o', 'ControlMaster=auto', '-o', 'ControlPersist=60s', '-o', 'ControlPath=/root/.ansible/cp/ansible-ssh-%h-%p-%r', '-o', 'Port=22', '-o', 'IdentityFile="/root/credentials/ansible_id_rsa"', '-o', 'KbdInteractiveAuthentication=no', '-o', 'PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey', '-o', 'PasswordAuthentication=no', '-o', 'User=ansible', '-o', 'ConnectTimeout=10', '172.16.27.30', "/bin/sh -c 'mkdir -p $HOME/.ansible/tmp/ansible-tmp-1443559407.84-218847375080367 && echo $HOME/.ansible/tmp/ansible-tmp-1443559407.84-218847375080367'"]
fatal: [lablogger0] => SSH encountered an unknown error. The output was:
OpenSSH_5.9p1 Debian-5ubuntu1.7, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: auto-mux: Trying existing master
debug1: Control socket "/root/.ansible/cp/ansible-ssh-172.16.31.69-22-ansible" does not exist
debug2: ssh_connect: needpriv 0
debug1: Connecting to 172.16.31.69 [172.16.31.69] port 22.
debug2: fd 3 setting O_NONBLOCK
debug1: connect to address 172.16.31.69 port 22: Connection timed out
ssh: connect to host 172.16.31.69 port 22: Connection timed out

fatal: [lablogger1] => SSH encountered an unknown error. The output was:
OpenSSH_5.9p1 Debian-5ubuntu1.7, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: auto-mux: Trying existing master
debug1: Control socket "/root/.ansible/cp/ansible-ssh-172.16.27.30-22-ansible" does not exist
debug2: ssh_connect: needpriv 0
debug1: Connecting to 172.16.27.30 [172.16.27.30] port 22.
debug2: fd 3 setting O_NONBLOCK
debug1: connect to address 172.16.27.30 port 22: Connection timed out
ssh: connect to host 172.16.27.30 port 22: Connection timed out


TASK: [nodejs_app | Put upstart script in place] ****************************** 
FATAL: no hosts matched or all hosts have already failed -- aborting


PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/deploy_logger_lab.retry

lablogger0                 : ok=0    changed=0    unreachable=1    failed=0   
lablogger1                 : ok=0    changed=0    unreachable=1    failed=0   

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Do you have a firewall set up? It looks like port 22 is inaccessible. Did you change the SSH port by any chance?