I am trying to connect django to managed database, i am not able to do.

After updating the django default database to correct values. i am able to run makemigrations and migrate command and also create super user. but when i login to the admin it gives me error of “no such table - auth user, OPERATIONAL ERROR”.

I noticed that even if i delete db.sqlite3 file, it comes back when i try to login, i think it looks for table in sqlite3 and not postgres.

  1. why db.sqlite3 file re appear after deleting ?
  2. how do i correctly configure my ?
  3. what is sslmode=require have to do with this ?
  4. do i have anything to do with server ca certificate.

Thanks Ranu


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I set database after gunicorn, so old wsgi setting was being used ie. sqlite, after restarting wsgi process, it started working with postgres.