Question

I am trying to install redis for php5.5, but getting php requirements error

when I execute: #sudo pecl5.5-sp install

I get the following error:

pecl/redis requires PHP (version >= 7.0.0, version <= 7.1.0, excluded versions: 6.0.0), installed version is 5.5.37
No valid packages found
install failed

This doesn’t make sense that pecl5.5-sp would have these php version requirements… anyone have any ideas?

(only reason I am using 5.5 is to mimic a live environment)

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I guess with pecl you can install an older variant. In this case it wanted to install 3.0.0, but I needed 2.2.8 for php5.5, so:

sudo pecl5.5sp install redis-2.2.8

…did the trick!

Verify it with this: php -r "if (new Redis() == true){ echo \"OK \r\n\"; }" from here