I am trying to install redis for php5.5, but getting php requirements error

July 21, 2016 3.9k views

when I execute:
#sudo pecl5.5-sp install

I get the following error:

pecl/redis requires PHP (version >= 7.0.0, version <= 7.1.0, excluded versions: 6.0.0), installed version is 5.5.37
No valid packages found
install failed

This doesn’t make sense that pecl5.5-sp would have these php version requirements… anyone have any ideas?

(only reason I am using 5.5 is to mimic a live environment)

1 comment
  • After some research, I think the basic answer is, “Running php5.5 on Xenial is hard / dumb”

1 Answer

I guess with pecl you can install an older variant. In this case it wanted to install 3.0.0, but I needed 2.2.8 for php5.5, so:

sudo pecl5.5sp install redis-2.2.8

…did the trick!

Verify it with this:
php -r "if (new Redis() == true){ echo \"OK \r\n\"; }"
from here

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!