Question

I can access my site via IP address but not via the domain (Ubuntu 20.04, Apache)

I had a domain name configured to point to my old droplet and it worked perfectly for several years. However, I recently created a new droplet using the marketplace LAMP stack (so it’s running Ubuntu 20.04 and Apache 2.4.41). After setting up my site on this new droplet, I updated my domain via the DigitalOcean admin area to point to the new droplet.

As far as I can tell, all of the DNS settings are correct and I’ve verified that the domain is pointing to DigitalOcean’s nameservers. When I ping my domain, either via the terminal or a site like https://www.whatsmydns.net/, I can see it resolving to the new droplet’s IP address. I can also access the site via the new droplet’s IP address. However, I can’t access the site via the domain name. I even tried editing my hosts file, but that didn’t work, either.

I’ve read through this tutorial – https://www.digitalocean.com/community/tutorials/how-to-install-the-apache-web-server-on-ubuntu-20-04 – although Apache was already installed as part of the LAMP stack. My Apache installation seems good to go, but still no site access.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

As it turns out, the issue was far more mundane: DNS hadn’t fully propagated. I just needed to be a bit more patient, I guess.

Hi there @jasonmorehead,

As you see the Droplet’s IP address when pining the domain, it indicates that the DNS is set up correctly.

What is the error that you get when you try to visit the domain name?

I could suggest the following things:

  • Check your Apache error logs:
tail -100 /var/log/apache2/error.log
  • Try clearing the cache of your browser

  • Check if your domain name has its own Vhost so that’s it might be loading from a different document root. You can the Apache Vhosts at /etc/apache2/sites-enabled/

Let me know how it goes! Regards, Bobby