I can not see public_html directory in FileZilla in Ubuntu 14.04 x64 VPS

August 7, 2014 4.9k views

Hello,
I am new to VPS servers. I have installed LAMP successfully by using the tutorial section which is fantastic. I am stuck in one place. Where I can upload my webpages using Filezilla?. When I login in FileZilla using the user : root, I can not see any public_html folder. I search some of the articles here and then some one says that there must be one user apart of the root user so I also created that. I have also make the required changes to setup the virtual host in apache by adding the .conf file. Here is the address

http://www.starvps.in/

This also shows the index files resides in the publichtml folder which is working fine. My only issue is how I can see that publichtml folder in FileZilla? I am using Ubuntu 14.04 x64.
Thanks in advance...
Ashish Joshi

1 comment
  • I have the same problem. Although I can navigate to the var/www/html folder in FileZilla that doesnt help me as i need to set Dreameaver up, usually I use my username, password, ip and the path which is usually public_html

    As such, im probably missiing the set up for that but I have a standard LAMP stack with proftpd and it all seems in order.

1 Answer

Where did you create the public_html folder? By default, on Ubuntu 14.04, the document root for Apache is /var/www/html/ Files placed in the document root are what get served by Apache.

To see what your document root is, open the file /etc/apache2/sites-enabled/000-default.conf It will look something like:

<VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>
Have another answer? Share your knowledge.