I can only access my Domain Name via IPV4 Address but couldn't access it using PTR Record

I have a droplet with an HostName. But the issue is that I can only access the domain with IPV4 but the couldn’t access it with PTR Record

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
November 23, 2023

Heya, @e7b6f80b2a5d4f1d8745e55bbd909d

As Bobby mentioned, If you’ve recently created a new droplet or made changes to the PTR record or hostname, the delay in accessing it could be attributed to DNS propagation. To verify whether the record is resolving correctly, you can employ our DNS lookup tool for a quick check.


Bobby Iliev
Site Moderator
Site Moderator badge
November 16, 2023

Hi there,

When you can access a server with its IPv4 address but not via its hostname or PTR record, it’s often a DNS resolution issue.

After setting up or changing DNS records, including PTR records, you need to wait for the changes to propagate across the internet. This can take anywhere from a few minutes to 48 hours.

DigitalOcean automatically create PTR records for Droplets if the name you give it is a valid FQDN.

Can you confirm that the PTR record has been correctly configured via this DNS lookup tool here:

If this is still not the case for you, you might have to rename your Droplet via the Control Panel so that the hostname is a valid FQDN. To do that,you would need to:

  • Login to the DigitalOcean Control Panel
  • Go to Droplets --> Click the Droplet you want to rename
  • Then, on the droplet detail window, click on the name of your droplet (you wouldn’t know you could)
  • Go to the Settings Tab --> Change the name in the entry field and click the check mark

Make sure you also edit your droplet’s hostname internally as well. Update /etc/hostname and /etc/hosts and reboot.

The PTR should be automatically adjusted in few hours due to DNS cache. If this is still not working after several hours, you can contact our support team as well.

Let us know how it goes.



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel